SOLVED - GameObject.FindObjectsOfType error

I got a problem with GameObject.FindObjectsOfType where i just get the error:

Assets/Scripts/networkingManager.cs(6,9): error CS0246: The type or namespace name `spawnPoint' could not be found. Are you missing a using directive or an assembly reference?

And it´s weird because the object I´m telling it to look for exist with that exact name.
This is what that part of the code looks like. I tried it outside of a print function and instead as a part of an array but that was not the reason for the error. It must be something with this part of the code.

print(GameObject.FindObjectsOfType<spawnPoint> ());

I hope this is enough info.

Thank you!

I solved it by adding a script called spawnSpot to the objects and changing the other code to:

GameObject.FindObjectsOfType<spawnPoint> ();


print(GameObject.FindObjectsOfType(typeof(spawnPoint)) as spawnPoint);

The thing is, that FindObjectsOfType looks not for the object named ThingYouSeek in the Hierarchy. But looks for the objects that have the ThingYouSeek.cs script attached to it.