[Solved] Materials of addressables lose most textures and settings when loaded in build

We use addressables to load scenes and objects (shelfs and bottles).

If we load them in the editor they look like they are supposed to.
If we load them in the build every setting except the baseMap (e.g. alpha clipping, transparency, normal map etc) seem to be gone.
We build the shelfs in the project and the bottles in another project.

The shelfs were missing their textures and settings, until we rebuilt them.
We rebuilt the bottles multiple times, but their settings are sill wrong in the build.

We tried to build a scene with a bottle in it. The bottle that was built in the scene looked right, but bottles loaded as addressables still looked wrong in the build.

Here you can see the same bottle loaded as an addressable (left) and placed in the scene (right) in the build (first) and in the editor (second)

We use Unity 2021.3.2f1 and Addressables 1.19.19

We found the problem. It was caused by a difference in the “High Definition RP”-Package. We created the bundles with “High Definition RP” version 12.1.6 and the project was built with “High Definition RP” version 12.1.7.

My guess in the editor it automatically used the correct shader, but it was stripped away in the build.