(solved) ml-agents-release_1 not working after install

i have been uning version ml-agents-0.15.0 for a bit with no problems upon installation.
i installed the version ml-agents-release_1 and now nothing works anymore, i followed up dependences and installations with pip, but this is what i got now...

(base) E:\Unity\2020\ml-agents-release_1>mlagents-learn config/trainer_config_my1.yaml --train --run-id=FJ_v101
Traceback (most recent call last):
File "C:\Users\DJ\AppData\Local\Programs\Python\Python37\Scripts\mlagents-learn-script.py", line 11, in
load_entry_point('mlagents==0.16.0', 'console_scripts', 'mlagents-learn')()
File "C:\Users\DJ\AppData\Local\Programs\Python\Python37\lib\site-packages\pkg_resources_init.py", line 489, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "C:\Users\DJ\AppData\Local\Programs\Python\Python37\lib\site-packages\pkg_resources__init
.py", line 2852, in load_entry_point
return ep.load()
File "C:\Users\DJ\AppData\Local\Programs\Python\Python37\lib\site-packages\pkg_resources__init
.py", line 2443, in load
return self.resolve()
File "C:\Users\DJ\AppData\Local\Programs\Python\Python37\lib\site-packages\pkg_resources__init
.py", line 2449, in resolve
module = __import
(self.module_name, fromlist=['name'], level=0)
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\mlagents-0.16.0-py3.7.egg\mlagents\trainers\learn.py", line 12, in
from mlagents import tf_utils
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\mlagents-0.16.0-py3.7.egg\mlagents\tf_utils__init
.py", line 1, in
from mlagents.tf_utils.tf import tf as tf # noqa
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\mlagents-0.16.0-py3.7.egg\mlagents\tf_utils\tf.py", line 3, in
import tensorflow as tf # noqa I201
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\tensorflow__init
.py", line 98, in
from tensorflow_core import *
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\tensorflow_core__init
.py", line 45, in
from . _api.v2 import compat
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\tensorflow_core_api\v2\compat__init
.py", line 23, in
from . import v1
File "c:\users\dj\appdata\local\programs\python\python37\lib\site-packages\tensorflow_core_api\v2\compat\v1__init
.py", line 664, in
from tensorflow_estimator.python.estimator.api._v1 import estimator
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator__init
.py", line 10, in
from tensorflow_estimator._api.v1 import estimator
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator_api\v1\estimator__init
.py", line 10, in
from tensorflow_estimator._api.v1.estimator import experimental
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator_api\v1\estimator\experimental__init
_.py", line 10, in
from tensorflow_estimator.python.estimator.canned.dnn import dnn_logit_fn_builder
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator\python\estimator\canned\dnn.py", line 33, in
from tensorflow_estimator.python.estimator import estimator
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator\python\estimator\estimator.py", line 53, in
from tensorflow_estimator.python.estimator import util as estimator_util
File "c:\users\dj\appdata\roaming\python\python37\site-packages\tensorflow_estimator\python\estimator\util.py", line 75, in
class _DatasetInitializerHook(tf.compat.v1.train.SessionRunHook):
AttributeError: module 'tensorflow' has no attribute 'compat'

and of course i can not go back to the previous version, got the same problem...
any help?

this is what i got when i try pip install mlagents

(base) E:\Unity\2020\ml-agents-release_1>pip install mlagents
Requirement already satisfied: mlagents in c:\users\dj\appdata\roaming\python\python37\site-packages (0.16.0)
Requirement already satisfied: pypiwin32==223; platform_system == "Windows" in c:\users\dj\appdata\roaming\python\python37\site-packages (from mlagents) (223)
Requirement already satisfied: mlagents-envs==0.16.0 in c:\users\dj\appdata\roaming\python\python37\site-packages (from mlagents) (0.16.0)
Requirement already satisfied: Pillow>=4.2.1 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (7.0.0)
Requirement already satisfied: pyyaml in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (5.3)
Requirement already satisfied: tensorflow<3.0,>=1.7 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (2.2.0rc3)
Requirement already satisfied: protobuf>=3.6 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (3.11.3)
Requirement already satisfied: six>=1.12.0 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (1.14.0)
Requirement already satisfied: grpcio>=1.11.0 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (1.27.2)
Requirement already satisfied: numpy<2.0,>=1.13.3 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (1.18.1)
Requirement already satisfied: h5py>=2.9.0 in c:\users\dj\anaconda3\lib\site-packages (from mlagents) (2.10.0)
Requirement already satisfied: pywin32>=223 in c:\users\dj\anaconda3\lib\site-packages (from pypiwin32==223; platform_system == "Windows"->mlagents) (227)
Requirement already satisfied: cloudpickle in c:\users\dj\anaconda3\lib\site-packages (from mlagents-envs==0.16.0->mlagents) (1.3.0)
Requirement already satisfied: google-pasta>=0.1.8 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (0.2.0)
Requirement already satisfied: wrapt>=1.11.1 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (1.11.2)
Requirement already satisfied: tensorboard<2.3.0,>=2.2.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (2.2.0)
Requirement already satisfied: astunparse==1.6.3 in c:\users\dj\appdata\roaming\python\python37\site-packages (from tensorflow<3.0,>=1.7->mlagents) (1.6.3)
Requirement already satisfied: absl-py>=0.7.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (0.9.0)
Requirement already satisfied: wheel>=0.26; python_version >= "3" in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (0.34.2)
Requirement already satisfied: scipy==1.4.1; python_version >= "3" in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (1.4.1)
Requirement already satisfied: gast==0.3.3 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (0.3.3)
Requirement already satisfied: opt-einsum>=2.3.2 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (3.2.0)
Requirement already satisfied: tensorflow-estimator<2.3.0,>=2.2.0rc0 in c:\users\dj\appdata\roaming\python\python37\site-packages (from tensorflow<3.0,>=1.7->mlagents) (2.2.0)
Requirement already satisfied: keras-preprocessing>=1.1.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (1.1.0)
Requirement already satisfied: termcolor>=1.1.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorflow<3.0,>=1.7->mlagents) (1.1.0)
Requirement already satisfied: setuptools in c:\users\dj\anaconda3\lib\site-packages (from protobuf>=3.6->mlagents) (45.2.0.post20200210)
Requirement already satisfied: google-auth<2,>=1.6.3 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (1.11.3)
Requirement already satisfied: werkzeug>=0.11.15 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (1.0.0)
Requirement already satisfied: markdown>=2.6.8 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (3.2.1)
Requirement already satisfied: requests<3,>=2.21.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (2.22.0)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (0.4.1)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in c:\users\dj\anaconda3\lib\site-packages (from tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (1.6.0.post3)
Requirement already satisfied: cachetools<5.0,>=2.0.0 in c:\users\dj\anaconda3\lib\site-packages (from google-auth<2,>=1.6.3->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (4.0.0)
Requirement already satisfied: pyasn1-modules>=0.2.1 in c:\users\dj\anaconda3\lib\site-packages (from google-auth<2,>=1.6.3->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (0.2.8)
Requirement already satisfied: rsa<4.1,>=3.1.4 in c:\users\dj\anaconda3\lib\site-packages (from google-auth<2,>=1.6.3->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (4.0)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\dj\anaconda3\lib\site-packages (from requests<3,>=2.21.0->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\dj\anaconda3\lib\site-packages (from requests<3,>=2.21.0->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (2019.11.28)
Requirement already satisfied: idna<2.9,>=2.5 in c:\users\dj\anaconda3\lib\site-packages (from requests<3,>=2.21.0->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (2.8)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in c:\users\dj\anaconda3\lib\site-packages (from requests<3,>=2.21.0->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (1.25.8)
Requirement already satisfied: requests-oauthlib>=0.7.0 in c:\users\dj\anaconda3\lib\site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (1.3.0)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in c:\users\dj\anaconda3\lib\site-packages (from pyasn1-modules>=0.2.1->google-auth<2,>=1.6.3->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in c:\users\dj\anaconda3\lib\site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.3.0,>=2.2.0->tensorflow<3.0,>=1.7->mlagents) (3.1.0)

SOLVED, i uninstalled mlagents and installed them again with pip