[Solved] Object Flickering When Camera Moves Around

I am experiencing some weird object flickering when my camera moves. These objects are quite large so I don’t know if that is contributing to the problem I’ve been having but it must be something to do with how far away they are since closer objects do not have this effect. I don’t know much about Unity rendering but any feedback on ways to stop this would be much appreciated.

Here is a video so show the problem visually: - YouTube

Thanks a lot


Turns out it was to do with the near clipping plane, I had it set to 0.01 and for some reason this was interfearing with the objects. I set it back to 0.3 and it stopped the flickering. Don’t know if it’s a bug or not.

This can happen when your geometry has several faces that are coplanar (very close to each other). For example an artist might model cloth or tree leaves with 2 planes, which look in the opposite directions.

This is sometimes done to a 2-sided geometry, but can cause these issues when rendered with a shader that doesn’t cull backfaces.

thatz is the not solution in case if you have FPS Shooter for shooting game
the hands and guns of the FPS will hide if we will increase the value of Clipping plannes

Thank you!!! I had my camera set to 0.01 also and setting it to 0.3 solved this! (I had large object- a terrain mesh + mountain and their intersection would flicker when I rotated the camera)

Following Vuforia ARCamera settings give extremely stable result:

I had the same issue. It works. I needed to put mine at 5, but worked! Working on a Strategy RTS game. Thanks

After loading your Scene with LoadSceneMode.Additive DO THIS instead:

You have to rebake your Occlusion Culling Data as a group otherwise your objects will start to disappear weirdly.
You can also simply turn off “Occlusion Culling” on your Camera.

What is Occlusion Culling?

See the explanation here:

How to Rebake my Occlusion Data?

  • In the Unity Editor, open the first Scene of the group that Unity will load at runtime. This becomes the active Scene.
  • Additively open the other Scenes in the group, so that all of them are open in the Unity Editor at the same time. (Drag it into your main Scene)
  • Bake the data for all Scenes. (See Window - Rendering - Occlusion Culling) Unity generates the data for all of the open Scenes, and saves it as Assets/[active Scene name]/OcclusionCullingData.asset. Unity adds a reference to this asset to all of the open Scenes.
  • Save the Scenes.

Cheers. Btw. changing the Near Plane of the camera to high values like 3 or 5 will coincidentially work as well but is a bad idea due to the side effects of clipping everything that is around you.