[Solved] Store test kit error

Hello,

I just finished my first Windows Phone game and wanted to submit it..

I build the application using Master configuration but when I try to run the automated tests, I get this error:
"The application package (XAP) is not up-to-date, Recompile and try again.
This app consumes native components. Change the solution configuration to Release and platform to 'ARM' and rebuild the app."

By building the application using Release configuration, tests do work, but development build message is shown..

I'm using Unity 4.5.2f1 with Visual Studio Express 2012 for Windows Phone.

Any help is very appreciated, thank you!

Are you using UnityScript in your game?
There was a bug that it was compiled with debugging enabled all the time. It was fixed in one of patch releases.

Hi Aurimas, thanks for your quick answer!


No UnityScript, C# only.

I suppose the master .xap that the WACK refuses runs fine on the phone?

Yes, it runs fine.

That's strange, I've no idea why it does that. Which VS exact VS version do you have?

Windows Phone Store allows submitting games as beta (it means it doesn't appear on the store as you publish it), so you could try submitting it there and it would automatically test it there.


Visual Studio Express 2012 for Windows Phone
Version 11.0.50727.38 WPTOOLSREL

I also installed the latest Visual Studio Express 2013 for Windows Version 12.0.30723.00 Update 3, but unfortunately the error remains the same..

Just to be sure that the solution is not in some way corrupted, I also rebuilt the game to a new VS solution, but nothing.

The game is live since today on Google Play, it's very simple, no networking, no sensors, even no audio. To have an idea you can check
https://play.google.com/store/apps/details?id=com.tiz777.TWOminimal&hl=en
maybe could help?

..this error won't let me sleep..

BUT, I've found a workaround!

I created a completely new and blank Unity project (even without any scene added to the build!) on another computer with Unity and VS freshly installed, and got same error.
But, by running the automated tests using the Release configuration then building again using Master, running tests did worked!

So, I re-built (again) my game to a new solution, did the same steps, and it worked too. Very strange, but for me is ok!

Thank you very much for your time, hope you'll find a better solution than mine :)

Sorry to bother again, but I guess the problem is still there :(

It seems to work if the sequence is the following:

  • open the VS solution
  • build Master
  • run test (get the error)
  • build Release
  • run test (no error)
  • switch to Master
  • run test (no error now)

BUT, I noticed that the "Application Package" read-only field under "Application Details" in the Store Test Kit, always points to the Release folder ([app folder]\Bin\ARM\Release\app.xap). So I guess it will not really do the test on the Master version.

Any suggestion is really appreciated, thank you!


I finally decided to try the way you suggested, and in fact it works, but it doesn't seem possible to pass from beta to public without resubmitting again the app.. so I'm locked again :(

Any other suggestions?

Just submit the game to the store. You don't have to complete the store kit locally to be able to submit it.

Nooo! That simple? :sweat_smile::sweat_smile::sweat_smile:

Thanks a lot Tautvydas!