[Solved] Too low resolution 2D Shadows

I’m using 2DLights and ShadowCasters in my game and the shadows are just too low resolution, didn’t find a fix for this anywhere, in the unity docs for the 2DLights it says there is a quality property but I can’t find it

191851-screenshot-4.png

Quality settings can be found in Edit>Project Settings>Quality. It is likely that the shadow settings are stored here too.

i’ve checked it, its already at max quality and nothing related to shadows

I found the settings. Due to your use of URP, the settings are contained within the URP file.

By default, this file is in Assets>Settings>Universal RP-…
Within this, there is a shadows tab which you can edit in the inspector tab.
The specific setting you are likely looking for is actually in the lighting tab which has a shadow resolution value.

Good luck!

If your using 2D URP it should be in the Renderer2D

(Assets/Settings/Renderer2D => Render Scale)