[Solved] Unity 2020 + Oculus Link Cable + Oculus App Can't Start Test + Unable to Start Oculus XR Plugin

Hi all,

I am developing for the Quest, it is the first day, was just setting up the environment, but it was such a hurdle! After a day’s battle with Unity 2020.1 and the Quest, finally I made it through. I’ll list the problems I went through, to provide you potential solutions if you also come across this headache.


**Rig:

  1. Unity 2020.1.5 and 2020.1.6

  2. the Quest 1

  3. a USB C to A cable of my own

  4. Razer Blade 15’ Advanced, early 2019 with RTX 2070

  5. Latest NVIDIA drivers and system updates**


Issues I came across:

  1. Finding a cable suitable for Oculus Link;

  2. Oculus App can’t start cable test

  3. Configured Unity according to the manuals, yet unity keep throwing errors “Unable to start Oculus XR plugin”


What I learned after a day’s trial and error:

  • I don’t have the official link cable or the recommended cable from Anker, but tried several USB C to C cables and C to A cables. Apparently those used for charging aren’t going to work, including the Apple C to C cable. Another possible reason for C to C cable not working could be a design problem of the razer model it self, see [Oculus Link with Razer Blade Advanced | Razer Insider]
    Nevertheless, I found a solid C to A cable that works well. So if you don’t have the recommended cable, might just try what you already have. Though, the original Quest cable doesn’t work.

  • So I found the cable, how did I know it worked? The Oculus app shows a perfect green dot under my Quest device, it is connected to a USB 3.0 port and ready to go. But it just wouldn’t do the cable test, no matter what I tried, it always says that the test can’t be started. Then I realized that for the Oculus Link to work, you need to confirm 2 pop ups in the Quest itself. One asks for data sharing, the next asks if you want to enable Oculus Link. After clicking “yes” on both, the VR environment changes into the Oculus Link envionment where you can have a virtual desktop. But still the cable test doesn’t run, so I gave up the test, turned to Unity.

  • After setting up Unity, I still faced many problems. They can be summarized into parts:

  • To add android support in the UnityHub, you do not only need to check the Android Build Support option, but also click the arrow to expand. Check Android SDK & NDK Tools, OpenJDK too. After the installation, unfold the arrow again, as it turned out twice in my trials that the UnityHub has only installed one, the other one wasn’t installed. So definitely make sure both are installed.

  • The biggest problem is that Unity constantly shows error:

    “Unable to start Oculus XR plugin”,
    “Failed to load displaysubsystem”,
    “Failed to load input subsystem”.

Restart unity, the Oculus app, unplug and plug in the cable, use USB-Hub extension, restart Quest, all didn’t work.

Then I thought, it might be a USB/port problem. So I checked Windows firewall → advanced settings, and checked the lists under “Inbound Settings” and “Outbound Settings”. I found two Rules of “Unity 2020.1.6f1 Editor”, one of them was blocked. So I enabled it, and tested Unity again. Still, no success.

  • I have read almost all I could find on google to solve the problems but no success. But then I read on Oculus manual, and opened the mobile app on my phone. I realized I didn’t have a developer account(first time developing for Quest), so registered and enabled the developer mode in the mobile app.

  • After some rounds of restarting the apps and messing around with the cables, I wanted to give up. So frustrated. I searched Oculus folder in Program Files and found the OculusDriver.exe. Click start, it asks me to restart laptop.

  • After the restart, I thought this would be my one last try for the day. It was too much.
    At this stage, I have one project in Unity 2020.1.5 and one in 2020.1.6. The one in 2020.1.6 was just the standard scene given in UWP. I opened the UWP project after the restart and thought, maybe I should add an XR Rig in the Hierarchy, be it room-scale or stationary. (Previously I watched some YouTube tuts, got quite confused with the XR Rig because tuts are all different… However, this time, after adding the XR Rig, THE OCULUS LINK FINALLY WORKED PERFECTLY!!! Also, the other project in 2020.1.5 suddenly worked like magic. / Though, the cable test still can’t start. LOL

So, I hope this can help you. Do try the OculusDriver.exe at C:\Program Files\Oculus\Support\oculus-drivers. After writing this down, I felt the Oculus driver might be the main issue that has caused the problems. But also try the other steps, maybe it was one added on another that in the end it worked out. Good luck!

Yes!

thank you, I was watching every tutorial possible to understand why it did not work on 2020 with oculus Link.

this did the trick!

(I am using the Quest 2 with a USB2 cable, and it works perfectly)

Thinks, running the OculusDriver.exe in C:\Program Files\Oculus\Support\oculus-drivers worked perfectly for me! :smiley:

Just want to say thank you for posting this. I was ready to give up on this problem and OculusDriver.exe in C:\Program Files\Oculus\Support\oculus-drivers worked. Seriously, Thank you.