[Solved] Unity Input lag - Mouse lag - 60fps feels like 30-40fps

Mouse movement in Unity doesn’t seem sharp/responsive compared to other games, making it difficult to aim in a twitch arena shooter.

In CS: Source the mouse input at 60fps feels very sharp, but in Unity it feels sluggish/delayed/laggy, as if it’s 40-50fps at best. Disabling vsync to get to 100fps or more is where it starts to “feel” compareable to CS: Source.

The solution is posted below!

Right-click your exported build exe > Properties > Compatability > Select “Disable desktop composition” and “Disable visual themes”.

This will allow you to turn vsync on in-game, lock to 60fps, and still have very responsive mouse input.

Windows 7 Aero seems to mess with the mouse input. This works for every Unity build I’ve tried, and with other games too.

This is NOT a solution, not even a good workaround. Will you post your customers if you wanna smooth input, you have to do this? And what about if you make games for multiplatform? You cannot do this on MAC or Linux.