(Solved) Why do my lights with Halo effects work in editor but not in build?

I have prefabs with light components, and mousepicking an object sets the light with halo effect to Enabled, allowing you to see current selection. This works perfectly in the editor play, but after building and running the exe on windows, no light/halo displays when clicking an object.

Edit: I verified in the build that mousepicking is working correctly, i can select and manipulate objects, they just don’t get lit up when selected the way they do when selected in the editor play mode.

Problem Solved! Apparently there is something a bit flaky with the Halo component since the new upgrade to 4.3. Somewhere along the way i removed the Halo component from my prefabs, and was just using the Halo effect on the Light component. This worked fine in the editor, but the Halo effects did not show in the windows build exe. I added a Halo component back into my prefabs, but did not enable it, and now my lighting Halos work just fine in editor and in build.