Some object don't cast shadows ?

Hello everyone !

I’m quite new to Unity and supposed to make a house as realistic-looking as possible for a augmented reality project.

I’m using lightmaps so I can keep performances to a maximum. I have a couple of point/area light and one big directionnal light for the sun outside. However, for some strange reasons, some objects refuses to cast a shadow. Or, they do, but not completely. For example (I desactivated the roof) :

http://img11.hostingpics.net/pics/715621screenunity01.png

(For the light’s settings)

http://img11.hostingpics.net/pics/634681screenunity02.png

The chairs cast a shadow inside themselves, but not on the ground. Same goes for the sofa and other stuff. On the other hand, the table and metallic thingy in the kitchen do cast a shadow on the ground. More annoying, the wall doesn’t cast a shadow at all.

Moreover, if I put the Directionnal on Realtime it still doesn’t cast shadow correctly. It looks like this instead.

http://img11.hostingpics.net/pics/406920screenunity03.png

Maybe because there is already a lightmap.

I have tried a few things already :

  • Cast shadows is on for everything, both lights and objects.
  • My settings are on Differed, Linear
  • Every object is Static
  • I changed Shadow Distance, but no results

(Side question, when using a texture on the ground, the picture is all difformed, regardless of the tilting setting. But not on the wall or furnitures ?)

Thanks for any tips !

Well, strangely enough, after some restarting, Unity decides to take pity on me and it works.

@Dridrix
Hello! I found a solution which may solve your problem, within this link: Why isn't my blender object casting shadows? - Questions & Answers - Unity Discussions

Basically you must go to the mesh renderer and make sure it can cast and receive shadows.