Sorry, this link is no longer valid

Hey there!

I tried now multiple solutions, but I keep getting this error ‘Sorry, this link is no longer valid’ everytime I open Unity. It keeps me from opening projects! I cannot do anything… Can someone please help me?

Actually the problem was caused by firewall, it block the file ‘c:\program files\unity\editor\unityhelper.exe’ so your account service cannot connect to the internet while Unity.exe can.
Just add this file to firewall exception and your Unity is back.

You should restart the computer, it did the job for me. If that doesn’t work then try clearing the browsing data (cached files and cookies) in your browser.

Weirdly enough, I can’t log on to Unity’s website in a Chrome’s Incognito Window, it gives me the same error you are experiencing. I believe it will be fixed soon.

Hi so on one of my laptops when installing Unity (latest version as of 25th September 2017) it started showing the same error ‘Sorry, this link is no longer valid’ when the application opens up.

I solved the problem and know what the issue is. In my case Windows Firewall decided to block parts of the Unity software, must have been some thing it automatically did during the installation.

What I did to solve it was to download and install an older unity from 3 versions ago, then Windows popped up saying it wants to block access to Unity and it’s Editor but I seleted that it’s save on the public and private networks.

Then it started working. Once that happend I went and downloaded the installer for the newest Unity software and it seems to be working now.

So your solution should be to download a Unity from 3-4 versions ago, allow Unity and it’s internet access in the Windows firewall and then go and install the latest version once that is working.

The way I solved this problem was by updating my windows.

I tried everything what you guys said and nothing worked, closed firewall, disable antivirues, cleaned all brower cache data, reboot computer,but it didnnnnnnnnnnnnnnnnnnnnn’t work. Help~I can not use unity any version even login through web brower~I want to die

I have figured out why this problem appeared. Here is the explanation that the official customer service replied to me:

Usually, this happens when there is more than one IP address hitting at the same time the and servers.
Please route your network traffic so that only one IP addresses are sent to the sites previously mentioned.

So I have two internet cable for my company, they are failover and automatic load balancing, So it’s possible that unity login page will recognize my different public network IP. Therefore, I have to switch the IP address of the PC where this error occurred between STATIC and DHCP. (Set it to DHCP if it was static IP and vice versa).
Refresh the page directly after replacement or reopen unity to bring up the login window.

Hope it helps. Good luck!

Those who are still facing this issue (like I did recently when I had to connect my laptop using mobile hotspot). Open the “Windows Defender Firewall with Advance Security” console. Under Inbound rule section look for all rules belongs to Unity (e.g. Unity Editor, Unity Hub). Right click on each rule and select Disable. Worked for me.