Sound plays even though Play On Awake is unticked

Hi guys,

I have a weird problem where a newly added sound plays at the start of the game even though Play On Awake ☐ is unticked.

Also I added a line in the Start()-method in my script audioSystem.sound.Stop() if that would help, but no such luck.
Google didn’t help with this issue, or maybe I didn’t use the right search terms.

Can anyone help me?

Well finally I got rid of the sound playing at the start. I just removed the sound file from the project and re-added it. Some kind of weird bug was going on there. Thanks for your help, guys :slight_smile:

  1. Make sure there are no other instances of the object in the scene.
  2. Check to see if the object is enabled (ticked) at runtime.
  3. Comment out all audioSystem.sound.Play() in your scripts, then enable the one by one to see if a function with .Play() inside is being called prematurely.

Sorry for the vague answers, it’s all I got with the information provided. Good luck :slight_smile:

I know, this is an old Thread, but I have the same issue in my Project (Unity-2018-2), re-adding the Audio-clip did not solve the problem for me. The audiosource.Play() function is only called when a UI button is clicked, which is not the case at start of the game. If I disable the audio source the sound does not play, so its that audio source which gets triggered at start. Any ideas?

not sure why, but found a fix by removing the audio source, changing the file name, and then adding it back. I think it might be caused by some invisible object playing the clip.