SourceTree Hangs (not responding) with Unity Large Project


  • Using Windows 10;
  • Using Visual Studio remote repository.
  • Project is a Unity project that is very large (90 GB’s+)
  • Source Tree is extremely slow and not responding after a click. Sometimes it comes back but then after a few seconds it starts hanging again.

History to when issue started:

  • I had a few thousand UNSTAGGED files, i selected a bunch of them and chose to STAGE them. After i waited for about an hour, i selected a few more hundred files and chose to Stage them too. This is how i always do it in the past.
  • The third time i again i selected a few hundred files and pressed Stage. But this time i got an error message back from Git saying something like, a git process is already in process. Manually remove the file index.lock and try again etc… Completed but with errors.
  • I waited for a long time, tried again, but same issue. At some point SourceTree also crashed too.
  • I then went into my unity project folder found the hidden folder called .git
  • Inside .git was a file called index, i deleted this file.
  • I Re-opened up sourcetree but from now its always very slow and hangs very often and says Not responding.
  • When the program does respond, i quickly go to a Stagged file and try Unstage it. Nothing happens and still shows the same error as above saying Completed with Errors, git process already in process etc…

Please Can someone help? Im very afraid to loose all my work, as due to the large size of project and the amount of time it takes to push the changes i only backup the project onto git once a month.
I was contemplating to delete the .git folder in my unity project and try open the project up again, but that might make things ever worse! I think some of the git files maybe corrupted or something.


A little late but for anyone having issues…
Did you add these to your .gitignore file like you should?