Splash Screen Shown in Batch Mode

When running Unity 2022.1 and 2022.2.0b2 in Batch Mode the Splash Screen is shown much/all of the time. This is silly. Please either disable the splash screen from appearing when the -batchmode flag is passed on the command line or provide another command line flag to disable it.

Hi! Unfortunately, I could not reproduce this problem on a newly created project. Could you please submit a bug report that contains your example project and full command line arguments list you are using when launching the project? It would help us a lot. Thanks in advance!

[quote=“justinas_p”, post:2, topic: 888786]
Unfortunately, I could not reproduce this problem on a newly created project.
[/quote]
Huh. I created a fresh project and tossed together a super simple script and was able to reproduce it. Here’s the script:

using System.Threading;
using UnityEngine;

public class Test
{
    // This is run with the following command (on macOS):
    //      /Applications/Unity/Hub/Editor/2022.2.0b2/Unity.app/Contents/MacOS/Unity -quit -noUpm -batchmode -logFile /dev/stdout -projectPath . -executeMethod Test.RunLargeProcess
    //  For even more time with the splash screen, remove the "-noUpm" option.
    //
    // Note that the splash screen will appear behind other windows, so you may
    //  need to go hunting.
    public static void RunLargeProcess()
    {
        // Sleep for 10 seconds, simulating a long-running script process
        //  doing good works for the user.
        for (int i = 0; i < 10; ++i)
        {
            Thread.Sleep(1000);
            Debug.Log($"Work item {i + 1} complete.");
        }
    }
}

The comment in the code above shows you the command to run (assuming you’re on macOS and your working directory is the project’s root directory). For avoidance of doubt, here’s what I use:

-quit -noUpm -batchmode -logFile /dev/stdout -projectPath . -executeMethod Test.RunLargeProcess

I have also verified that the issue occurs when you reduce the command to the following:

-quit -batchmode -projectPath . -executeMethod Test.RunLargeProcess

Which is sort of the “minimal flags” case.

The Splash Screen also appears behind other windows when it does arrive.

I have also filed a bug [IN-11342] about this. The test project includes a screenshot of the issue.

[quote=“SonicBloomEric”, post:3, topic: 888786]
(assuming you’re on macOS and your working directory is the project’s root directory)
[/quote]

Just a random guess: you didn’t specify which OS you were on and Justinas tested it on Windows :p. It illustrates why bug reports are so valuable: in addition to just your message, we also get all your system information and logs which can be crucial to figuring out bugs.

1 Like

Thank you for providing more details, it was really helpful! I'm glad to tell you that the fix is ready and it is on its way to land.

Tautvydas - that's correct, initially, I was testing it on Windows.

1 Like