Sprite background

Sprite is visible in the scene, but not in a build or in game view.
Tried sorting layers etc. changing position, rotation, scale. Nothing worked so far.
Alpha isn’t affected at all during play mode.

Any ideas?

Does it (or any parent) have the tag EditorOnly? It will strip it out of the build.

Or, perhaps some piece of code is turning it off, setting alpha to zero or otherwise moving the sprite when you hit play.

If it’s far out, perhaps it’s outside the cameras clipping planes.

The problem was the Z position. By resetting the position of the sprite (or just the Z position) it worked out for me.

The thing I probably did wrong was setting the sprite as a child of the camera and then resetting the position etc. This changed the Z position to the exact same as the camera, clipping it through the “lens” (near clipping plane).