Sprite not visible?

I’m sorry this has been asked before, but none of the solutions have worked for me. I made a simple background in photoshop and saved it as a PSD. Unity automatically set it as a Sprite (2D & UI) under import settings. When I dragged it in the hiecharchy, I can see it in my scene view but NOT my game view.

I tried putting the sprite in its own layer, making the layer appear first, and also setting the “Order in Layer” to a value such as 5. No dice.

alt text

Any advice on how I can make this sprite appear in gameview? Thanks. I’m using Unity 4.6b18

In the scene view, drag the main camera over the sprite.
Also make sure that the camera’s z value is lower than the sprite’s z value in the transform’s position.

Make sure your camera clipping near value is set to -1.
Hope this will help, i faced similar problem an d this was the solution.

None of the above worked for me.

I am doing a Vuforia Project with the AR Camera, the camera always defaults to 0,0,0 on Play.

My clipping near plane cannot be set to -1. The lowest value is .01 for near.

I cannot move the camera and I cannot set the clipping plane to -1.

Sprite plays fine in scene view. How to I get my sprite to show up in game view?

EDIT
Got it working!

  1. I set the canvas to Screen Space -
    Camera

  2. Then set the Render Camera to
    Main Camera.

Use UI → Image

Don’t use 2D Object → Sprite

135762-image-not-sprite.png

maybe you are in wireframe mode , i had the same issue i put it in shaded mode and works

“Also make sure that the camera’s z value is lower than the sprite’s z value in the transform’s position” That’s what did it for me. I had an Empty object with Sprite child. I set the z value for the Sprite to be 0 but not the Empty object. Once I fixed the parent object then I was able to see it.

Canvas render mode: choose screen space - camera
then choose render camera to be the main camera
then the sprite renderer will display

My camera is set to -10 and all sprites to 0. The background shows up but the character does not. The layers are set in the correct order.

Edit: It looks like when I enter play mode the z coordinates of the player and camera reset to bad values. I don’t know why. Suspicious it may be a bug in one of my scripts. Will look into it further.

Edit: In the script that makes the camera follow the player, I had it attached mistakenly to the player in addition to the camera (should be to the camera only), so the z value of the character was getting messed up. Removing the script component from the player fixed the problem!

Takeaway: Make sure your scripts are not modifying your z-positions or layering during runtime!