Sprites are pixelated even after changing import settings.

Hi,

I am well aware that this issue has been addressed a bunch of times already, but I’ve tried pretty much everything I could find and it didn’t solve my problem.

I am working on a 3D game with 2D UI elements. These elements come up with a pixelated edge which I never really noticed while developing, but definitely showed up once I made a build.

In the import settings, I’ve already tried :

  • Changing the pixels by Unity to 96
  • Changing the wrap mode to “Clamp”
  • Changing the filter mode to “Point”
  • Augmenting the Max Size
  • Setting the Compression to “None”
  • Do these overrides on the appropriate platform
  • Making sure that assets are not being compressed in the Unity Preferences
  • Unchecking the Mip Maps

I’ve also tried importing a large resolution texture, as well a a lower resolution texture. I’ve tried importing a .psd instead of a .png… Nothing works.
The weird part is, the asset itself seems fine on the preview, but the sprite “attached” to it, looks terrible in the preview…(you can really see that on the letters)

I don’t know what else to try at this point,
Please help me :frowning:

My problem ended up having nothing to do with the import settings of my sprites. It had to do with the resolution of my retina screen. When I would launch the build, I wasn’t using the appropriate resolution settings, which made the sprites look pixelated, for some reason.

I figured it out when I tried to launch the build on a PC with a 1920x1080 resolution and the sprites looked fine. After that, I chose the appropriate settings for the build on my Mac, and it worked fine.