SQLite problems when building the project.

Hello there!

I’m currently involved in a project where we develop a game that utilizes SQLite to connect to a database file.
Everything works flawlessly within the editor, we can connect, read and write to the database.

However, when we build the project we can no longer read or write to the DB.

We have tried the following:

  • Verified that the path to the DB file is interpreted correctly.
  • Various solutions and combinations of where to put the sqlite dll, including a plugin folder.
  • Running the build with administrative rights.

As far as we can tell, the connection is successfully established but we seem to lack any rights to access the file.
We’re currently running Unity Free, and using C# for our scripts.

Any ideas of how we can solve this? Thanks in advance :slight_smile:

The problem must have been with the computer we tried to compile on, or the settings we used on that computer. When we built on another computer, it was all fine. If anyone experiences the same kind of issues, make sure you build settings are not set to webplayer. And if that doesn’t help, try on another computer.