Staging Area "is library" error!

I am trying to follow the instructions for integrating Unity project into Eclipse
I have scanned all the instructions available on net.The problem I am facing is whenever I add " Library project"(the one that is created through staging area) to my custom android project Eclipse first shows a green check,after applying it and clicking ok if i check it again by going to the properties of “my custom android project” the library reference is missing with a red cross. I’ve tried this with other Libraries it works perfect but only when staging area is selected as library it reproduces this error.
Am I missing something in Staging Area? Please Help.

My Eclipse Version is Indigo Service Release 2
ADT version 18
and Unity version 3.5.3f3

Is anybody else having this problem?or Am I totally missing something?

Update:

Ok now I’ve updated to ADT version 20 and the problem is still there. What I think is there is something missing in the Staging Area. Is it a Version Problem? Somewhere on the threads I read the Unity 3.4 didn’t have this problem.Our Team will soon be shifting to mac for IOs version of this same project. Is there an integration problem with Xcode too? Or is it only with Eclipse?
Should I downgrade my Unity version?

Ok I am posting this as an answer coz I solved it by not adding the Unity Project as library. I simply moved the required assets of unity project from staging area to my custom android project plus the android manifest file and then following the usual extending the main activity as UnityPlayerActivity.
Important point is to keep the API level and bundle identifier name the same and “adding the classes.jar and other required external jars(if you are using Vuforia’s plugins for AR)to the java build path”
Might be useful for others who are struggling with the same.