Standalone fullscreen does not work! Unity 4.1.2

Hi there,

We have built some demo scene for our current project to show, but once we play the .exe file, if we enable the Fullscreen tick on the splash screen, when starting the game our monitor flashes black and immediately returns to Desktop. However, the game is indeed running, as we can see its process in the Task Manager. Is there anything we are missing, something we must do or code in order to get this working? We are pretty sure that everything in our scripts as well as Player Settings is OK, but we don’t want our final game to be played just windowed. Any ideas?

By the way, we are working with Unity 4.1.2f1, Dx11, and the Build is targeted to PC, Mac & Linux Standalone x86 - x64. It is weird since the x86 version DOES work. Thanks!

downgrade your unity to 4.1.0 or Enable Display resolution dialog in player settings. new version of unity have some problems read here
http://forum.unity3d.com/threads/175263-Unity-4-1-1-update-rolled-back-sorry

So, fullscreen in x64 works by DISABLING the Display Resolution Dialog option in Player Settings before building. When unchecking that option, the SplashScreen does not show at all, but instead the game runs directly.