Standalone player giving "is not responding" dialog after first scene load on Ubuntu

My Linux standalone build gives the error pop-up “program name is not responding” after the splash screen when the first scene loads. The game keeps playing just fine though but you have to press ESC to get rid of the dialogue in the background before you can do anything.

This only seems to happen on Ubuntu 18.04.1 LTS (the current version) as it works fine on SteamOS older Ubuntu versions, Mac, Windows, Android and iOS.

Is there anything I can do to avoid this? A way to stop the main thread from jamming? I am weary of making my game available to Linux users with this bug in the most common Linux OS.

I’m using Unity 2018.3.3f1



It seems that in Ubuntu 18.04 they changed the Desktop from ‘Unity’ → ‘Gnome’. (Note, Unity here is nothing to do with Unity3D, it’s just the name of the old Desktop)

There seems to be issues with Gnome and the ‘Not Responding’ window, and it can be issued and block all input until clicked. But, it seems that it can get ‘hidden’ in the background and therefor you can’t click it.

They have tried to fix it for some other apps, but I have the latest Gnome patch, and it doesn’t fix it for Unity3D. See here: Bug #1740869 “<something> is not responding window is constantly...” : Bugs : gnome-shell package : Ubuntu

The only way I could get my game to work was to install the old Desktop and switch to that, instead of using Gnome. Then it all worked fine.

I’m not sure if this is a Gnome or Unity3D issue that needs to be fixed. Really, I’m not sure why Unity games are so unresponsive when ‘loading’ (I get this on Windows also since a few patches of 2018.3 ago). But, Gnome shouldn’t really hide the window like this.

Did anyone find an answer to this? I am running into the same issue.