Standard Assets errors

Hi, I am new to Unity and have been experiencing some problems starting a new project with standard assets.
I get the following errors messages…

Prefab has multiple Transform components! Removing them automatically would not be safe.

SpeedTree materials need to be regenerated.
SpeedTree materials need to be regenerated.
SpeedTree materials need to be regenerated.
SpeedTree materials need to be regenerated.

Broken YAML file(Assets/Standard Assets/2D/Animator/2dCharacterAnimator.controller). Local file identifier (110283043) doesn’t exist!

Broken YAML file(Assets/Standard Assets/2D/Animator/2dCharacterAnimator.controller). Local file identifier (110283043) doesn’t exist!

Prefab has multiple Transform components! Removing them automatically would not be safe.
UnityEditorInternal.InternalEditorUtility:GetGameObjectInstanceIDFromComponent(Int32)
UnityEditor.DockArea:OnGUI()

I’m using Unity 5.2.1f1 on windows 10. Any help would be appreciated. Thanks.

Some of those errors, like the speedtree, YAML, and transform errors, show up because Unity is still doing the compiling process. Once that’s finished (the spinner in the bottom right goes away) you can hit the Clear button on the console to remove them.

As for the other errors, such as what @b_rez is getting, are you sure you’re importing the correct version? There’s 2 versions of the Standard Assets now. The old one was renamed to ‘Standard Assets for Unity 4.6’ in the asset store, but if you had already downloaded it and trying to use in Unity 5, it may still show as just ‘Standard Assets’ in the menu.

Also, are you actually deleting the downloaded package, or just removing them from your project? Unity keeps downloaded packages so if you want to use them in another project you don’t have to download them again. If the download is outdated or corrupt, you’ll need to manually remove it. For me on Windows 10, they’re stored at "C:\Users\UserName\AppData\Roaming\Unity". Note that ‘AppData’ is a hidden folder, so you may need to go into the View menu and turn on show hidden items.