Sticky keys on all Unity apps

I seriously have nowhere else to ask about this:
On various games (and some non-game apps as well) I have either WASD or Arrow Keys sticking. What I mean is that, for example, after loading a top-down shooter, my character moves southwest without me pressing a single key. This happens on Firefox, IE10 32-bit and IE10 64-bit (Windows 7).

Stuff I’ve tried:

  • Running the browsers as administrator.
  • Uninstalling and reinstalling Unity Player
  • Adding the websites hosting the Unity app under “trusted” sites.
  • Held WASD and/or Arrow Keys all at once for 5 seconds.

I don’t know what else to do…

Alright, robertbu’s answer was correct. I had a joystick attached to the computer and its Dead zone was a little too sensitive. Disconnecting the device did work. Thank you.

Start a new project. Begin by exporting all your work as packages and re-importing them to the new project. Do not use a different character controller and fpsmovement script/motor script either than the standard ones. You can change them when exporting your game, but for first debugging, stick to the unity one. Have a look at the Unify (it is spelled with an “f”, not a “t”) community wiki for scripts that will help you. Most of all, remember not to meddle with the axis-es in the Unity Input Manager. I had the same problem and now it works fine.

Tell me if you get anywhere. Always happy to help…

This is happening to me. This started happening ever since I plugged in my Xbox Controller. Now it is stuck permanently to the left + up or W and A on the keyboard. I got my controller and pulled the joystick left and immediately unplugged it and now it was temporarily sticking to the right! But when I restarted Unity, it went back to left. It could be my controller, but I have no idea on how to get it to stop going forward and left!

EDIT: This even happens with the controller unplugged, so unplugging it will not solve the problem.

Bump

Austint30 had the exact same scenario as myself.

I know this is an old thread. The solution is as follows:

Uninstall “VJoy virtual joystick” from your machine.

Works great now. This needs to be pinned to an important place in the forums.

Updating my graphics drivers and icue fixed it for me