Still problem with El Capitan and building for iOS?


Please try the patch suggested by clausdoerge below, reposting link here:

It worked for me and if it doesn’t work for some of you I think this fact will be useful info for the developers at Unity. :slight_smile:

I try to build my project for iOS using my El Capitan machine, however Unity 5 crashes every time…

I have seen similar issues for people using the El Capitan beta and then it was alegedly fixed, however I am running the final version (10.11) and the latest Unity 5 (5.1.0f3) and still get similar issues.

The crash log is below (truncated, can submit the full but it is obviously very long):
Process: Unity [7381]
Path: /Applications/Unity/
Identifier: com.unity3d.UnityEditor5.x
Version: Unity version 5.1.0f3 (5.1.0f3)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Unity [7381]
User ID: 501

Date/Time: 2015-10-04 12:34:03.278 +0200
OS Version: Mac OS X 10.11 (15A284)
Report Version: 11
Anonymous UUID: 0BDC8732-3744-1D45-225B-04375B223E5C

Sleep/Wake UUID: 224FAB5F-FFE1-4AFB-BD25-ADB24E2F7934

Time Awake Since Boot: 220000 seconds
Time Since Wake: 9800 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[NSURL length]: unrecognized selector sent to instance 0x122590f80’
Performing @selector(ok:) from sender NSButton 0x12de16fe0
terminating with uncaught exception of type NSException
abort() called

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff9a104bd2 __exceptionPreprocess + 178
1 libobjc.A.dylib 0x00007fff93dc14fa objc_exception_throw + 48
2 CoreFoundation 0x00007fff9a16e0ed -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
3 CoreFoundation 0x00007fff9a0753d1 forwarding + 1009
4 CoreFoundation 0x00007fff9a074f58 _CF_forwarding_prep_0 + 120…

Not sure what you mean by that?

This problem is apparently inside Unity when it tries to build my project… in fact I got the same when trying to build the Unity Labs sample project for iOS so it doesn’t seem to be something wrong I do in my project?

It seems odd that noone else got this issue, since it seems very fundamental … ?

All I do is press the Build button…

Same issue .my unity is 4.6.3 professional.
When i build iOS project , it will not crash , but nothing is going to happen .When i try building again and again , then unity crash .
There is my issue OS X el capitan , Unity 4.6.3 can't build iOS project - Questions & Answers - Unity Discussions

Got the latest version from here, and it seemed to fix my issues.

Unity 4.6.9 Released and they have fixed this issue in it.

Download it from here:

Have the same exact issue. Clearly related to OSX El Capitan.