Stop Shooting Myself

I would like to make a simple shooter on a capsule, but I don’t want my shoot position goes in to the player itself if the player looks down, it should like like this:
(The red point should be the shoot position)


Any help will be appreciated.

If you meant that you are shooting yourself i would try creating different collision layer and deactivating the collision of player with himself at
Project Setting → Physics2D —>Layer Collision Matrix

@wewewu Maybe try moving the gun a little bit further, but not to far, and not to make it look to bad you can go to the camera and increase the clipping