Strange Collision

I have made a race track and imported it into my scene. The track has a ramp and a mesh collider. When my car reaches the ramp it goes straight through it! Can I make collisions more realistic?

Try setting the mesh to convex by checking the convex box in the mesh collider settings if you didn’t already. If you are going fast it could pass through the collision point between frames so I suggest that you go into your project settings and increase the simulation rate. I believe it only does calculations 6 times per second by default so you can turn that up much higher to avoid clipping