Strange squeaks from system unit on two different PC

Situation is following: we have a simple 3D demo, where unity logo shows up, than simple terrain is loading (resolution of the screen is 1024x768). Terrain does not have any objects other than skybox and 2 sprites. Sprites are NPC prototypes that circle through a simple waypoints. As soon as logo comes up, system unit begin to squeak (very strange sound), and video card begin to work in a very "hard" way, just like we have a modern game based on unreal 3 engine with tones of hi-res textures and millions of polygons in camera view but we do not, its just terrain and 2 sprites. This continues to a moment when tester calls inventory screen (png as background and sprites as items). After that, squeaks dissapear, but GPU still have bad times. This happens on a two diffirent configurations:

1) i5 760, GF 460 GTX, 450W power unit, Win7 x64. PC Speaker on

2) Core 2 Duo e8600, GF 9600, 400W power unit, Win7 x32, PC Speaker on

Loudmask Have you read my post? You think, 460 GTX is an old videocard? And what about graphics? I said, we have only PLAIN TERRAIN and 2 SPRITES ON IT! By the way i send this demo to some people who have different configurations, from old dual cores CPU's and GF9800 to i7 processors and 480 GTX cards - and they have not this problem.

Statement In fact i dont have PCI-e soundcard, just built in motherboard type. But you discribed those noises a lot better than me. I didnt mentioned that i also sometimes have this scream in my headphones, but this happens time to time after some restarts of .exe file. But mostly it came from system unit but i cant say precisely what cause it. I dont think its PC speaker.

You can do one of two things:

  1. Try not to make your graphics too complex. Allow mipmaps of your textures and shorten the amount of polygons.

  2. Upgrade your video cards.

I had this squeaking too and saw that my GFX card(ATI 4870 HD) was running on 90%+ hihg levels but only when running my project outside the editor. Back then I encountered this when doing basic DirectX graphics too. The problem was solved by limiting the framerate (don't ask me how did i do that back then) [this was the story of my life sry]

so I looked up the documentation and found that this solved my problem: I just set it to 60 and haven't had any problems since then and I'm more than fine with a framerate around 60.