subfolders missing from standard assets folder (Unity 3)

Hi all,

Have just downloaded Unity 3, and created a terrain. However, when I tried to apply a texture to the terrain (grass, etc), I found that the standard assets folder in the project panel did not contain a 'terrain textures' subfolder, so I could not do this. When I expanded the standard assets folder it only contained these subfolders: character controller and skyboxes. Missing were the prefabs, blob shadow, camera scripts, fonts, scripts etc.. folders.

While trying to do this, I noted an alert message at the bottom of the screen: " Error while importing package, couldn't decompress package ". This would seem to indicate that the subfolders were missing because they did not import when starting Unity (yes, I did tick them to be imported).

Short of uninstalling Unity, and then reinstalling, can anyone please suggest a way to rectify this? Any help greatly appreciated, am new to Unity!

Thanks very much. Greg. Perth, WA.

Hi,

I got the same problem. the Standard Asset Package was there in Unity 2.6.

I am going to call them tomorrow and see, will let you know.

I live in Sydney.

Black-Widow

Hi,

Spoke to Unity and the items that were in the Standard Package for Unity 2.6 have been distributed around to other folders. So search the other packages and you will find the items.

Black Widow.

Hi again,

Managed to sort this, all you need to do is: right click on the standard assets folder, select 'import package (asset)'. Browse to where the standard assets folder is stored (usually C: program files, etc..). Then select the file you want, eg. terrain textures, and click open (Win 7) to import that asset into the Unity folder structure. This worked fine for me. Thanks. Greg.