Suddenly all animator avatars and SkinnedMeshRenderer mesh references "Missing" for me but not teammate

I’ve been working on a project with some people. Meta files are in version control (git). Teammate pushes a branch with a new model for an enemy on it. When I look at it it’s invisible. I see that all the mesh references are missing (but the animator avatar reference is still there). I ask him to do a re-clone and see if it happens for him, he does and it is still visible for him.

So, I decide to re-clone as well, and I do it in another directory. I open that and not only is it invisible but now the older version of the enemies are also invisible, and now when I look on any of them they are missing mesh references and now also missing animator avatar reference. Even if I check out the main / non-feature branch this is the case.

Now that is strange, but what is even more inexplicable is after I reopened the original clone of the project now they’re all missing there too! Even though nothing has been touched on that version of the repo at all. My best guess is there’s something locally about my Unity that is messed up, but I have no idea what.

Any ideas how this could have possibly happened?

I’m still not 100% what happened but it seems that my partner at some point replaced .fbx files with blender files and I didn’t have blender so it automatically worked for him but not me. I guess the fbx must have stayed locally for me or was cached or something, but once I did this it did this. Once he exported the blend files to fbx it all worked again.