Surge - Tween not moving out of Delayed state

One of my @pixelplacement Surge tween’s seems to be behaving very oddly, when I call the tween function with a delay of 0 (or any delay value), it just stays in the Delayed state, no matter if I manually call start/resume/pause/etc. But this only seems to happen when I load the asset in via Addressables. When I just place my prefab in a test scene and tell it to play play the tween it works fine.
My tweening function is:

_tween = Tween.AnchoredPosition(target: Rect, endValue: target, duration: _introDuration, delay: 0f);

I have tried calling it in a coroutine after waiting a couple frames after instantiation as well just on Start/Awake/etc but nothing seems to make it leave the Delayed state. Is there something about addressables or some other thing i might be doing that could cause a tween to get stuck coming from a specific object?

All my other Surge tweens in the game work fine, this seems isolated to just this load.

Okay Im dumb, It’s because i was getting an NRE in my test scene that was stopping my call to setting the timeScale to 0. Now to figure out how to get the tweens to still work even if the time scale is 0.

It’s easy! there is an obeyTimescale argument in the tweening functions. Problem solved!