Survival Shooter Tutorial - Player Animation Not Playing Correctly

I’m on video #2 of the survival shooter tutorial, using Unity v5.1.2 on OSX Yosemite 10.10.3.

I’ve completed the PlayerAC animator controller and the PlayerMovement script per the tutorial.

When I hit play to test, the player moves and follows the mouse pointer as expected, but the animations are incorrect. For example, the ‘Move’ animation is only showing the gun moving (while the original that came with what I imported is showing footsteps), and the ‘Idle’ animation does not show anything (while the original shows yawning and what not).

I tried recreating the ‘PlayerAC’ animator controller, and could see the animations working fine within the animator up until I attached it to the player object. I also tried attaching the animator from the ‘_CompletedAssets’ folder, and the same thing occurred (the animations appeared to be working fine until they were attached to the player object).

I’m not seeing any issues come up in the console, and I’m not seeing anything about this online. Anyone out there have any thoughts?

Expanding on @lvrodrgues 's response, he is correct, the solution can be found here: http://forum.unity3d.com/threads/survival-shooter-tutorial-part-2-error.308208/

Here is the text solution, as posted by @Socrates:


Open the Animator Controller.
In the Animator window, select the Transition from Idle to Move.
In the Inspector, uncheck “Has Exit Time”.
This prevents the rest of the animation loop from playing before you transition to the next animation.


This makes sense actually, if you don’t give the animation any time to complete before triggering the next animation, the player will go from idle → to walking → back to idle almost instantaneously because Input.GetAxisRaw from the PlayerMovementScript is feeding either 0 or 1;

I had the same issue, I found that I had ended up with an animator component on both the player game objects in the hierarchy, having one on both caused the player model to fail to animate while gun continued to animate, removing the animator from the model fixed the issue.

Hi. Founded solution in http://forum.unity3d.com/threads/survival-shooter-tutorial-part-2-error.308208/

Update:

I still have the same issue, but I’ve tried and ruled out a couple more things.

  1. The ‘Player’ pre-fab under completed assets that came with the tutorial works as expected when dropped into the scene.

  2. I took the script that I wrote for ‘PlayerMovement’ and applied it to the working pre-fab above, and it continued to work as expected. So I can rule out an issue with my script.

I compared the completed pre-fab asset to the one I had set up, and made sure every setting, as well as the order of all the components was the same, to no avail.

Is it possible this is just a bug within the tutorial?

@ckeaney - I’m having the same issue. Did you find a solution?

I have exactly the same issue. Did any one find a solution?

un-ticking exit time in the animator worked for me.

Go to the transition between IDLE and MOVE and un-check exit time. It worked for me.

Click the transition line, uncheck “Has Exit Time”, then the player move with the animation right.

I just wrote the next statement:

bool walking = false;
***
//some code
***
void Animating(float horizontalMove, float verticalMove)
{
		if (horizontalMove != 0f || verticalMove != 0f) {
			walking = true;
		} else {
			walking = false;
		}
		anim.SetBool ("IsWalking", walking);
}