Syntax Error in Instantiate

I’ve made some incredible progress in my latest project only to be stopped dead in my tracks by what seems to be a syntax problem. Part of my script is verbatim of the script from Design 3’s Hoop Jones, except mine is for one player instead of three. I got the same error when I built and tested per their tutorial. The problem originally was instantiating a ball at the position and transform of my player. I’d get a “transform is not a member of object” error. Here is my code:

var newball;
static var tempBasketBall :Rigidbody;
var Transform[0]; 
var ball1 :Rigidbody;
var canControl1 = true;
var destroyTime :int = 6;
var player1 :GameObject;
var b1Parent :Transform;
var yVel :float;
var zVel :float;

function Start()
{
    ball1 = Instantiate (tempBasketBall, pos[0].position, pos[0].rotation);
    ball1.transform.parent = b1Parent;
    }

function Update() {	
    if(Input.GetButton("Fire1"))
    animation.PlayQueued("fire", QueueMode.PlayNow);   
   }
   function TapFunction() {
    animation.PlayQueued("fire", QueueMode.PlayNow);
    ball1.transform.parent = null;
    ball1.useGravity = true;
    ball1.velocity = transform.TransformDirection(0, yVel, zVel);
    MakeBall1([pos]);
    canControl1 = false;
    player1.animation.PlayQueued("idle");
    }


function MakeBall1(pos)
{
    yield new WaitForSeconds(1);
    ball1 = Instantiate(tempBasketBall, pos.transform.position, pos.transform.rotation);
    ball1.transform.parent = b1Parent;
    canControl1 = true;
}

function DestroyBall(ball:Rigidbody)
{
yield new WaitForSeconds(destroyTime);
Destroy(ball.gameObject);

}

My first runs I got the transform is not a member of object error, referring to line 36; the 2nd line in the MakeBall1 function. It was suggested I remove ‘transform’. I tried removing ‘transform’ but then it tells me ‘position is not a member’. I need both because I want the ball to instantiate at this position and transform. Then it occurred to me to add a ‘0’ to the brackets in the exposed variable at the top as it is in the Start function. The ‘not a member error’ went away, but I get the following even stranger error; " NewBaller1.js(3,14): UCE0001: ‘;’ expected. Insert a semicolon at the end. " There IS a semi colon at the end of line 3…Soooo close
and yet so far. Maybe there is some other glaring problem that I’ve messed up that has blocked my code from compiling but that’s
why I’m seeking expert advise. Can someone please help me clear up this situation. Thanks in anticipation! DigitalD

var Transform[0];

is not valid. Take that line out. It may be messing with the line below it. Declaring ball1 as Rigidbody should have taken care of the problem. But if you want to be really sure, ad ‘as Rigidbody’ at the end of the Instantiate lines (before the semicolon of course)