System out of memory when opening a project

Hi, when i open a project (doesnt matter what project) in Unity 5 i get this error:

Could not allocate memory:System out of memory!

Trying to allocate: 34359738360B with 16 alignment.
MemoryLabel:Dynamic Array

Allocation happend at Line 370 in

Memory overview
[ALLOC_DEFAULT] used: 45520175B | peak: 0B|reserved:

[ALLOC_GFX]used:4485216B|peak: 0B | reserved:

[ALLOC_CACHEOBJECTS] used:1172288B|peak: 0B|
reserved: 18874368B

[ALLOC_TYPETREE] used:32776B|peak: 0B| reserved:

reserved: 92274688B

I even get this error when i open a just created project!!
Does anyone know how to fix this???

Sorry to bump an old post, but I confirm; deleting the cache fixes the problem. I didn’t have an %APPDATA%\LocalLow\cache folder. I went to %APPDATA%\LocalLow\Unity. In there, I found The folders “Browser,” “Caches,” and “WebPlayer.” All 3 of them have caches to delete inside of them. My cache was over 10GBs and I fixed my error by deleting it.

Anyone who comes in here from Google can have a fix that took me a long time to find.

On windows 7 (unity 5) i just had this and fixed it by deleting the contents of the cache folder.

C:\Users"current User"\AppData\LocalLow\Cache

My Problem was gone just after:

  1. Full uninstall ALL Unity’s
  2. Manually search & delete all Unity folders
  3. Clean regestry with CCleaner
  4. Manually search & destroy rest of all unity regestry entries.
  5. Reboot
  6. Install Unity.

This issue still exists. I just deleted 10.1 GB from my GICache folder, and problem seems to be gone. Unity 5.3.1f1.


For me, I realized Windows disabled paging files (virtual memory) so it made sense that Unity kept running out of memory. I just had to re-enable paging files. The exact process varies between the different versions of Windows, but for my Windows 8.1, here’s a screenshot:

Paging file settings in Windows 8.1

Like it was said before can be a problem because of GICache. Make sure your Main Drive (usualy C:/) has enough space.

You also might be trying to allocate too much memory.

Go to the unity menu.
File >> Preferences >> GICache.
Try to delete your current Cache and if needed change the drive where the cache is saved.

Problem still exists in Unity 2019.2.21. Fixed by deleting project’s Library folder.