"target platform" and "architecture" sectors missing from build setting

Hi new to unity and working my way through a tutorial. (I’m running windows 10 and unity 5.6.1f1)

When I got to the Building part, I noticed that I could not build for mac or Linux.
With a quick bit of googling, I find the ==MISSING A MODULE?== Just reopen the Download Assistant :slight_smile: forum post.
Now after following the instructions(I think correctly but I’m not one to rule out operator error) and instead of adding in Mac and Linux to the Target drop down like I was expecting, the “target platform” and “architecture” options are missing.

screen grab showing how the problem looks

unsurprisingly trying to build without selecting the target platform does not work, but I didn’t know if the error messages would help to find out whats wrong

screen grab of console

Things tried:

  • Googling (All I seem to get is topic on Missing modules(i.e. them not beeing installed), not anything on a module missing options)
  • opening another (previously made) project
  • creating a new project
  • un and re installing
  • switching the platform away from “PC, Mac & Linux Standalone” and back again
  • and lots of turning my pc off and on

Any help would be very much appreciated

Regards
Nick

p.s.
reposed as I posted in the wrong space

I tried uninstalling again. instead of selecting all the options I wanted I started with just the editor.
the two options were back, YAY! but I was not happy not knowing why.

so I started off to adding back in MVS no problems. I Then added the other modules in one by one and the options were still there, no problems.
At least up until adding in “Facebook” after that the options were missing again and in the “Facebook” build setting there are 3 error messages
pic of error messages

  1. the top one can be simply fixed by doing as suggested by selecting the newer SDK version

  2. also the second, adding in my app id

  3. but why would it say in the Facebook settings about no standalone module loaded(again ti worked immediately before installing the Facebook module) and when trying to follow the “open download page” link I get

    An error occurred while processing your request.
    Reference #132.5f57dd58.1495714334.103c5da

uninstalling and reinstalling without the facebook module fixes the problem.
I have replicated this on 2 clean installs on my main PC and on a 2nd PC(both Windows 10 64bit)