Teammate can't open Unity Collab project

I have a team member who claims they can not download a project for a Unity Collab but here’s the catch. I think I did everything right.

I’ve added this individual to my organization (they have a seat), I’ve added them to the project as a manager, and that should be it… right?

Everyone else has access to the project except for this individual. Now this person had shared their screen for the Unity Hub, I noticed that this person didn’t have the “Refresh Online Projects” button for his Unity Hub. The project doesn’t even appear on their screen and yet they are connected to the internet. They’re logged in with the same email address I’ve assigned to him. This person said he had this issue for another project but was resolved by him making the project. Another thing to note that he is using his personal email account rather than his organization email.

I also sent them the project files and maybe hoped they can connect to the project by going to Unity Editor → Collab and connect the organization but he said it was greyed out (I’m not sure of the legitimacy of this).

What am I missing? At this point, I just want this individual to get back on track with us.

The First Thing I Would Try Is To Ask Them To Restart Their Computer! If That Doesn’t Work Then Ask Them To Re-install The Unity Hub. If All Else Fail’s, Try Unadding Them Then Re-Adding Them To The Project/Organization.

That’s The Best I Can Say!

@XxTorionxX I have the same problem but nothing worked

@XxTorionxX Tried it all, still not working :frowning: