Terrain grass invisible in editor

I can’t see any grass painted on terrain inside the Unity Editor (2018.2.5f1). I checked out a demo scene from the asset store (this one), but it is the same there (1). When I set the scene render mode to i.e. RenderPaths (2), I can see where the grass should be. When I use a LightweightRenderpipelineAsset in the graphics settings (3), I can actually see the grass, but the rest is messed up and pink (seems like Terrain isn’t supported by this yet). So I guess it has something to do with the graphics settings, but they are all set to default. Any ideas?
123962-screeny2.png

A solution that worked for me was to add the WavingGrass shader to the “Always Included Shaders” list under Edit → Project Settings → Graphics.

You can get the shader from the Unity Archives. Click the Downloads dropdown for the version you want and select “Built in shaders”. After downloading and extracting the folder, move the shaders you want into your Assets folder. The grass shaders specifically are in: builtin_shaders-[version]\DefaultResourcesExtra\TerrainShaders\Details.

Copy the ones you want to your Assets folder, then you should be able to add them to the “Always Included Shaders” list. I had to hit play after making this change, to see the grass render.

Hope this helps!