Terrain is entirely black in editor

I don’t know what caused it or when it started, but for some reason the terrain will turn black as if it were entirely unlit. This is the same if I enter play mode, however it does not affect builds.

It seems to occur whenever I go into Play mode and switch scenes via Application.LoadLevel from there. Doing so won’t affect the scenes in Play mode, but once I exit the terrain turns black and stays that way until I go in game and load the scene up with the same method. Even once I do this, it still stays black if I go back to the editor.

A possibly related problem I have is that sometimes when I load the scene in the editor (but not in Play mode) or when I alt-tab and tab back in, the scene will appear darker for a short while. Clicking on it will cause it to lighten up after a short period of time. Until this happens, the problem will persist into play mode as well.

I noticed this bug in Unity 5 too.
I tested and i discovered whats the problem.

1.Click on Window (from file menu) and then click on Lighting.

2.Now select Ambient Source (From Lighting) to Color or Gradient BUT NOT TO SKYBOX!

3.Change Reflection Source(From Lighting too) to custom BUT NOT TO SKYBOX!

4.Do this for every scene you have.

Hope I helped : D

@LukeZaz Same problem - and none of these solutions worked for me. What did work for me, however, was disabling and re-enabling the terrain in the editor; after a few seconds, the lights popped back on.

I was having the same problem not too long ago so maybe I can help. For me it was the texture/materials default emission colour. I would start the game but when coming out of the game and back into the scene editor all of my levels objects would turn black.

Select the terrain (assuming you have a material assigned like grass or dirt) and open up the shader to look for one of the settings using the “black” colour by default. You would need to change this to match the colour of your terrain.


I just had the same problem!! I got my terrain to show up by reloading my grass texture. Like this:

  1. Find the grass in your project.
  2. Select it, then change the resolution Max Size.
  3. Click the Apply button.

After doing that my terrain showed up, but it was extremely bright from all the lights I made in the scene trying to light up my black terrain. :open_mouth:

I know this isn’t the best solution, but it works for me for now.

I had the same problem, my entire world turned black, but the issue was relatively simple. I by mistake dropped the material on the skybox and it turned black. What you need to do it, go to Windows>Rendering>Lighting settings and now remove the material from the skybox.

But I could only reach to the solution by reading part solution of @PixelSpartan.
Thanks, everyone.