Terrain lighting issue...

I have a day/night cycle fully working however at night when i have my point lights turn on from torches this happens:

Many possible explanations but at a guess you’ve exceeded your pixel light count so those torches are lighting per-vertex rather than per-pixel, and the light intensity is therefore getting interpolated along that line because it’s the side of a triangle in your terrain.

If you have many (dynamic) lights in your scene you might want to switch rendering path to deferred rendering. Doing so will allow each pixel to be correctly lit by the lights that are in a position where they have a “field of view” of that pixel. There is a higher performance cost for deferred rendering but it is more performant when you have several lights som in some cases your FPS might actually go up when you switch to deferred rendering.

You can select rendering path in the graphics settings. There is a comparison of the different rendering paths in the manual