Terrain showing through on Android build.

I’ve been having a problem with terrain showing through using forward and deferred rendering. The problem fixes itself when I change rendering to legacy deferred, but I’d rather use forward rendering. Does anyone know a solution?

Check the “Clear Flags” property of your camera. Generally you will want to set this to “Depth only”. Your problem might be related if it is set to “Do not clear”.

After a lot of messing around with the build setting, updating my Android SDK fixed this problem.