terrain texture is blurry

i have a project in unity with a terrain in a scene.
recently when i opened my project and the scene that i had. then the texture was really blurry/bad quality.
when i zoom closer to the map then the texture dissapers in large chunks, then when i zoom out again the texture is back but still very blurry. when i start the game then the terrain has no textures.(unless i then change "base map dist. to 0 instead of 1000) then the texture is back but the grass is just like one color only.
here’s some pictures to show the problem:
alt textalt text

Go to Edit>Project Settings>Quality, and then choose your quality settings and modify them so they fit your needs.

this one?

alt text

i had to make a whole new project and import this map into. then it worked.

try the latest version of unity.
sometimes older versions can give this sort of problems.

The “near” terrain is drawn one way, using a high-res blend of what you painted on. It’s drawn for the square chunks near you – the gray areas from your first picture. Somehow yours got broken – textures misplaced, shader bunged up … .

The “far” terrain is drawn using a low-res “base map,” which is a pre-built blurry snapshot of the good terrain. BaseMapDistance says how far away to start using that blurry base-map. Setting it to 0 says to use it everywhere (so the 2nd picture is exactly how it should look.) If you have WorldOfWarcraft, you can lower graphics settings and see that they also use this trick.

I am having the same problem. No way to fix it. Changing the distance for detail (BaseMapDistance) makes absolutely no difference. It is as if Unity dose not see what is set there… I am using basic unity 4.1.1f4. I tried every “solution” I could find on this forum.

It is a nasty bug that basically makes the terrain editor is useless for me.

try to go to edit, graphics emulation, no emulation… in my case it had OpenGL es 2.0 selected… after i changed that, it worked for me… but on my iphone (using es 2.0) it shows the same blurry textures… seems to be a glitch of some kind, but don’t know how to fix that yet…

For anyone looking for a solution to this problem, check that your splat map has an alpha channel and that all of the alpha values are zero. This is what solved it for me.