Terrain texture layers not working after universal render pipeline install,Textures on terrain not showing after removing universal render pipeline

My god i’d love some help with this one, I’m new to Unity so it might be something brazenly obvious.

So I imported the universal render pipeline for the sake of learning how to create moving water, this seems to have been a big mistake. I have since uninstalled the package but it has not removed my problem, it turned all of my materials pink due to the shading properties and I know how to fix that (messing around with prefab settings) But when I now go to create a layer to texture my terrain any texture I choose is just simply invisible when I go to use it with the Paint Texture option, I’VE TRIED A LOT OF THEM.

I’ve even tried starting a new project and the problem is persisting, scriptable render pipeline settings is set to None (Render Pipeline Asset) so I’m assuming it’s now just the built in standard settings. I’ve come from Unreal Engine and so far very simple things are proving extremely difficult in this editor.

Please Help.

If anyone else runs into this problem I found a simple but not obvious solution: in the “Paint Details” tab click Edit Details then Add Detail Mesh. Add any random object in the Detail section, click Add, and paint with the detail mesh and Unity should correct itself and reload the missing grass textures.
Figured this by accident after hours of trying to solve the problem. Good luck!