terrain textures become low res after save and quit unity?

Thank you for checking out this question.

Today as i was working on unity3d (4.1.2f1) i encountered a problem, my textures for my terrain turn into a shiny super low resolution.
so i checked other questions and none have the same issue i have, you see, after you zoom out on the terrain, it goes back to normal, but if you zoom in, it goes back to the terrible texture. And i have been trying to figure out a solution to this problem for over 3 hours now and with no luck :frowning: has anyone had this problem before???

and im not receiving any errors from the console.

im fairly new to unity and my last project, i never had this issue.

I have the same problem, I collected some answers:

If the textures appear to be the correct sizes, but are just super blurry. Look at BaseMapDistance (under the far-right Gear menu in Terrain.) If it somehow got set really low (or your terrain is huge) Increasing that may create a “crisp” area.

“Modern” terrain engines pre-make a super-low-res image of the entire terrain. For anything that counts as far away,

they just use that low-res baseMap (for speed.)

Hey guys, same thing happed to me a moment ago and I think I figured it out.

If you have DirectX11 turned ON, you HAVE TO have a “Nature/Terrain” material assigned to the terrain. If you don’t,

the textures go blurry.

If you don’t want to have a material assigned to terrain (because for example you use a TriPlanar script), turn OFF

DirectX11 in Player settings and reset Unity. Textures go back to normal :slight_smile:

Hope this solves your problem :slight_smile:

I had this same problem but then it turned out to be the shaders that I was using were bad. I selected the terrain in

the hierarchy then I went to Assets->Select Dependencies. Then I deleted all of the shaders and it worked perfectly. I

hope this helps.

Have a look at Project Settings > Quality and the import settings of your texture.

inside the terrain go to settings and change the base map distance to 0. Inside the quality settings set the quality

to max, go to your texture and change resolution, set to BiLinear, if none worked delete the TerrainAssets folder(or

whatever texture pack ur using) and reimport it

Try them!