Terrain Tree Prefab Orientation Prob

Hey, Kinda a newb here..My imported tree model isn't painting as a terrain tree. When it does paint, the orientation and scale are off. I read a bit and found out that I can basically put my tree into a Empty Game Object and fix the size and rotation orientation with that. But when I applied the Empty Game Object (which holds my tree) and try to paint the trees in terrain, i'm getting an error: The tree Prefab_Tree_Regular couldn't be instanced because the prefab contains no valid mesh renderer

What step am I doing wrong? (I also realize later, I'll probably need to add a collision capsule to my tree prefab but yeah...)

I would really appreciate if anyone has any info on this matter

Anyone else find a solution for this/ anyone else get this same problem?

So I got my tree model into an Empty Game Prefab, so that I could scale it up and reset the orientation. I think it will work now if the paint the trees on the terrain, but I get a "no valid mesh renderer" error...I searched other users threads both on 'answers' and 'forums' and I found this:


It's exactly my problem! Anyone figure out a solution? I'm using Max to export.

I finally figured out how to have the correct rotation orientation on a tree prefab exported from 3dsMax to be used in Terrain painting. What I had to do was in Max,

1)Go into the Hierarchy tab. 2)Under 'Adjust Pivot' dropdown, select your "Affect Pivot Only" button. 3)While the button is pressed, look into the 'Alignment' dropdown. 4)Press the "Align to Object" button. (This is pivotal to the orientation setup!) 5)Select your 'Rotation' gizmo (hotkey "E") 6)Rotate only on the Y axis exactly 90degrees. (I turn on angle snap to get it perfect) 7)After the rotation, turn off the "Affect Pivot Only" button. 8)Select your move gizmo (hotkey "W") If you did the process correctly, your Y axis should be now pointing Up and Down in altitude. You did it!

Also i thought it would be important to note that when scaling these trees in Max the scaling won't transfer over in Unity's terrain tree painting either unless:

1)Scale up (or down) your tree model. 2)After you have scaled to your liking, go to Hierarchy tab again. 3)In the 'Adjust Transform' dropdown, look for the "Reset" subcategory. 4)Just press the "Scale" button, resetting your scale to be 100generic Max units again. 5)What this means is, if you're exporting with the default FBX settings, which is "inches", 100generic units converts to 1 inch. This is the perfect equivalent to your scale being 1generic unit in Unity.

Hope this helps a lot of people who had that same problem I did! -GreenHat