Terrain trees not casting shadow

We’ve baked the lights in our game, and the trees that I’ve painted onto the terrain will not cast a shadow. If I drag the tree prefab in from the project folder, the shadows work correctly. How can I enable shadow casting for the trees that I painted onto the terrain?

Make sure all the trees are marked as “static” and when your terrain is selected clic the cog icon and make sure receive shadows is on. Also you might want to check that your light source has shadows enabled. When baking, make sure to use the “all” button for the baking and if that won’t work. Try clearing the shadow map and reloading all the trees for the terrain using the reload button in the trees bar.