TerrainData is missing splat texture 3.

I have done some research to this error and the answer I found was to reassign the textures to the terrain which I tried but it didn’t clear the error. I also tried building the lighting and deleting the other terrains in the project but it still doesn’t work. The terrain looks fine in the editor but it doesn’t show in the build. Is there a way to fix it without redoing it?

Hello sorry for my bad english language .
i solved this:
for example if u choose this texture “GrassHillAlbedo” search for it in your project>Standard Assets>Environment files in unity ,
then click on it , then in inspector window under the advanced option for “GrassHillAlbedo” u can find a check box that says “Read/Write Enable” mark it and then apply in the bottom . make sure u are not in play mode when you are doing this . and remove your texture and add it again then start play mode it should worked.

and for be more careful u can also change your whole default save project from Users>public>…. to a new location in your PC that don’t be in public folder .