Text Changes to Black

Hi there. I’ve been facing an issue for the past couple hours that I cannot figure out. When I run my game all of my Text objects that are not a special font, such as the defualt Ariel or Comic sans, change to black and will not change back when I try setting the color in the editor. The text will remain black until I save the scene, at which point they snap back to their proper color.

Something interesting that I noticed however is that If is slowly scale up the font size the text will change to light blue. Even though this is not the intended color. I tried making a simple helper script to attach to auto set colors and font sizes, that did nothing.

I have no idea whats happening or which direction to approach this from. Please Help.

  1. Disable camera ( just untick it )
  2. Enable camera

Color will be back to yours. But only until your next action with UI in editor. Usualy this solution helps before you want test play.

I find that reimporting the fonts fixes the issue for me

Assign a Material to the Text component. You’ll see your color come back.
(It still does this in 5.5… don’t know why. It will be fine without a material, and then poof! The text turns black and the only fix is assigning a material).

Getting help from Kizmiaz’s comment, I tried unticking Occlusion Culling on the main camera, and it’s resolved.

@glitch452 - What they are saying is correct. You have to exclude your UI from the cameras Culling Mask. In your scene, select your camera. Then select Culling Mask dropdown in the inspector panel. Untick UI:

For me switching from scene to scene fixed it idk if it will work but worked for Me!

Just generate the lights again