Text displaying in game view inside unity, but not in actual running game

Hello!

I'm running Unity 3d on a Macbook, and I just can't figure what's wrong (neither can google). My GUI texts appear when I run the game from inside Unity, but as soon as I export the game nothing shows up in Labels or Buttons. The problem appeared after creation of a GuiSkin, but I've double-checked everything and the fonts seem to be set.

I use an imported mac font, but I doubt it's the source of the problem, because in another scene this font shows up perfectly (but with no GUI skin). When I tried using another skin it worked (but with another font, so I still don't know where to look for the source of the problem). Maybe someone could point me in the right direction?

Anyway, any help would be greatly appreciated.

If you switch to game view , press 'maximize on play' this will show the game the same as you build it. Maybe the location of your GUI text isn't good. I had the same problem to. Sorry for my bad english :D