Text does not display when Maximize on Play is selected

I have 4 text objects on a canvas, and they all display correctly and in the correct positions when I run without the Maximize on Play option.

But when i run with the Maximize on Play option, I lose 2 of my text objects. All of the text objects are on the same canvas and they are all using the same Font, Font Style and Line Spacing. The two text objects I lose are smaller in Font Size (the ones I lose are 50, the ones that still work are 125.)

The canvas Render Mode is Screen Space - Camera, using the main camera, and a Plane Distance of 100. The Sorting Layer is default and Order is 1 (I’ve tried other values for the Order with the same result.) The canvas scales with screen size and my Reference Resolution is 1920x1080 / Expand.

Let me know if this is enough information, and any help would be appreciated!

I have same problem, i think you should try change the font size or resize the text space.

use anchors to fix the position of text so that they stay on the canvas even if you maximize on play

I had the same Problem. The anchors were set correctly and the text still wasn’t there when maximizing.
For me the solution was to set “Best Fit” active in the Text Component.,I had the same Problem. The anchors where set correctly and in maximized Display the text still wasn’t displayed.
Solution for me was to set “Best Fit” in the Text Component. By Default it wasn’t active.