texture alpha channel not importing


I made an alpha texture per the directions at http://unity3d.com/support/documentation/Manual/HOWTO-alphamaps.html. When I tried to import the texture, I used Assets/Import New Asset and navigated to my PSD file (which had an alpha channel), but after the texture was imported, it did not have an alpha channel. Am I doing something wrong in the import? Thanks.


There is some hint of transparency somewhere in your RGB layer. When this exists, then Unity will import the transparency of the file in, as an alpha channel, instead of the alpha you explicitly set in the Channels panel. I don't know of any tool to detect where this is occurring, and it's easy to have it happen in the normal process of creating a PSD. The typical thing to do, to fix your problem, is to just create a solid layer at the bottom of the stack. Personally, I use a Solid Color fill layer, because it doesn't require a whole image worth of pixels, like a regular layer would, so the file size of the PSD is not bloated.

I see that the post is old, but I had such problem just now.

As I understood, Unity searches at leat one fully-transparent pixel in picture, and if it find it - PSD transparency imports instead alpha, else it will import PSD Alpha as is.

So if you want to import Alpha channel - do as Jessy said, and if you want to use PSD transparency - ensure to have at least one FULLY transparent pixel in your PSD.

Just to post again about this issue; If you still have trouble, use the trim option in Photoshop and then change your texture import settings to Advanced>Non Power of 2>ToNearest. Not sure why this happens, but that should fix it if you tried everything else.