Texture Array Shader works fine in Editor, renders flat black in Windows build

I have an instanced texture array shader with six 2048x2048 textures. It renders fine in the editor (in Windows) but without displaying the textures in a Windows build (target platform is PC, Mac & Linux standalone).

In previous builds I made for Android some objects using the shader had pixelated surfaces (but others, instanced with differing uv offsets were fine).

I could use help with the Windows build problem in particular. The shader is used in a material that is on objects in the scene. Adding the shader to the Always included list in player settings → graphics didn’t help.

Okay I had to set all the textures to read/write-enabled and combine the arrays again. It works now.

I had the same issue, though the OP answer didn’t work for me.

I fixed it by adding the array field in the shader’s properties field.

eg. _MyArr ("My Tex", 2DArray) = "white" {}

I only had it defined inside CGPROGRAM, but as it turns out that’s not enough!